We identified an issue impacting data pipelines and models in the US region, which resulted in degraded performance. Our engineering team investigated the root cause and has now resolved the issue. All services are currently operating normally.
Posted Mar 05, 2026 - 07:33 UTC
Investigating
We identified an issue impacting data pipelines and models in the US region, which resulted in degraded performance. we are investigating the issue.
Posted Mar 05, 2026 - 07:29 UTC
This incident affected: US Cluster (Data Pipelines, Models).