A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2026 - 17:19 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 04, 2026 - 17:02 UTC
Identified
The issue has been identified, and we're working on the fix. We want to ensure all the impacted users that this will be mitigated very soon.
Posted Feb 04, 2026 - 17:02 UTC
Update
We are continuing to investigate this issue.
Posted Feb 04, 2026 - 16:45 UTC
Investigating
We have identified lag buildups across pipelines for some of the teams in the US2 cluster. If you're facing some lag with data delivery, kindly rest assured that we're working on it as our topmost priority. Apologies for any inconvenience. We will share further updates here in some time.
Posted Feb 04, 2026 - 16:44 UTC
This incident affected: US2 Cluster (Sources, Data Pipelines).