Issue with UI feature - Download Usage Summary

Incident Report for Hevo

Resolved

The incident has been resolved.
Posted Apr 28, 2025 - 12:08 UTC

Monitoring

A fix has been implemented and we're monitoring the results.
Posted Apr 28, 2025 - 11:30 UTC

Identified

We were able to identify the root cause behind the failing component. A fix is currently being implemented.
Posted Apr 28, 2025 - 10:55 UTC

Investigating

We have identified an issue with a UI component on the Billing page: Usage Summary > Download Usage Summary. The reports being delivered through email may not be accessible for some time. Please reach out to Hevo Support (through Live Chat or support@hevodata.com) to get the reports, in case this is blocking you.

We will soon post the next update on this incident.
Appreciate your patience!
Posted Apr 28, 2025 - 10:31 UTC
This incident affected: US Cluster (UI Console, Billing), Europe Cluster (UI Console, Billing), India Cluster (UI Console, Billing), Asia Cluster (UI Console, Billing), US2 Cluster (UI Console, Billing), AU Cluster (UI Console, Billing), and US GCP Cluster (UI console, Billing).