Google Ads Pipeline Failures Affecting Ad Group and Campaign Objects

Incident Report for Hevo

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 05:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2026 - 00:12 UTC

Identified

We are currently seeing failures in the Google Ads connector affecting the Ad Group and Campaign objects following the recent upgrade from version 21 to version 24. Our Engineering team has identified the root cause and is actively working on implementing a fix.
Posted Jul 30, 2026 - 06:37 UTC
This incident affected: India Cluster (Sources, Data Pipelines), Asia Cluster (Sources, Data Pipelines), AU Cluster (Sources, Data Pipelines), US GCP Cluster (Sources, Data Pipelines), US Cluster (Sources, Data Pipelines), and Europe Cluster (Sources, Data Pipelines).