Stripe Source - Issue Ingesting Charge/Refund Objects Data

Incident Report for Hevo

Resolved

We're closing this incident as it has been resolved at our end.
Posted Jan 28, 2026 - 17:23 UTC

Identified

The issue has been identified on Stripe's end, and our team is checking with Stripe's support regarding a concrete root cause. To fix any Stripe pipelines with failing objects like Charge, Refund, or Dispute, please generate a new restricted API key and configure the same in the source settings.

Steps mentioned here:
https://docs.hevodata.com/sources/fna-analytics/stripe/#obtaining-the-api-key
Posted Jan 28, 2026 - 17:22 UTC

Investigating

We are currently experiencing issues retrieving data for the Charge and Refund objects from Stripe. Our team is actively investigating the issue.
Posted Jan 28, 2026 - 07:56 UTC
This incident affected: US Cluster (UI Console, Sources, Destinations, Data Pipelines, Webhooks, Public API, Alerts, Team Management, Billing, Transformation, AWS Marketplace, Models), Europe Cluster (UI Console, Sources, Destinations, Data Pipelines, Public API, Alerts, Webhooks, Team Management, Billing, Transformation, AWS Marketplace, Models), India Cluster (Sources, Data Pipelines, UI Console, Destinations, Public API, Alerts, Webhooks, Team Management, Billing, Transformation, AWS Marketplace, Models), Asia Cluster (Sources, Data Pipelines, UI Console, Destinations, Public API, Alerts, Webhooks, Team Management, Billing, Transformation, AWS Marketplace, Models), US2 Cluster (Sources, Data Pipelines, UI Console, Destinations, Public API, Alerts, Webhooks, Team Management, Billing, Transformation, AWS Marketplace, Models), AU Cluster (Sources, Data Pipelines, UI Console, Destinations, Public API, Alerts, Webhooks, Team Management, Billing, Transformation, AWS Marketplace, Models), and US GCP Cluster (Sources, Data Pipelines, UI console, Destinations, Public API, Alerts, Webhooks, Team Management, Billing, Transformation, AWS Marketplace, Models).