Google Ads source: Issue while fetching "campaign" reports

Incident Report for Hevo

Resolved

This incident has been resolved.
Posted Oct 26, 2025 - 07:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 25, 2025 - 16:50 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 25, 2025 - 10:57 UTC

Update

We are continuing to investigate this issue.
Posted Oct 24, 2025 - 07:10 UTC

Investigating

We are currently facing issues while retrieving "Campaign" reports with the help of Google Ads API. The team is actively investigating the issue along with Google Ads support.
Posted Oct 24, 2025 - 06:59 UTC
This incident affected: India Cluster (Sources, Data Pipelines), Asia Cluster (Sources, Data Pipelines), US2 Cluster (Sources, Data Pipelines), AU Cluster (Sources, Data Pipelines), US GCP Cluster (Sources, Data Pipelines), US Cluster (Sources, Data Pipelines), and Europe Cluster (Sources, Data Pipelines).