UI Services Down due to AWS outage

Incident Report for Hevo

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 11:51 UTC

Monitoring

We are now observing healthy responses for requests routed through CloudFront, and the UI should be accessible across regions. The team is still monitoring this.

Latest update from AWS (11:16 AM UTC):
https://health.aws.amazon.com/health/status
Posted Jul 16, 2026 - 11:19 UTC

Identified

AWS is investigating the issue with Amazon CloudFront. For further details, please refer to the AWS STATUS PAGE: https://health.aws.amazon.com/health/status
Posted Jul 16, 2026 - 09:13 UTC

Investigating

Current logs show that none of the backend processes are impacted. We are currently investigating the issue with UI.
Posted Jul 16, 2026 - 08:38 UTC
This incident affected: US Cluster (UI Console), Europe Cluster (UI Console), India Cluster (UI Console), Asia Cluster (UI Console), US2 Cluster (UI Console), and AU Cluster (UI Console).